Yes. Plugin must be activated as site wide.