• Creator
    Topic
  • #1536
    robiul.islam
    Member

    Hi,

    We have purchased this plugin for this site: http://cti2.qdrive.ca/
    But the plugin dose not work properly. The sliding effect dose not work. please check the site.

    I deactivated all other plugin to check the issue but the problem still there. I am using “the7” premium theme.

    Could you please check this issue and solve the problem?

    Regards,
    Robiul

Viewing 7 replies - 1 through 7 (of 7 total)
  • Author
    Replies
  • #1537
    MillaN
    Keymaster

    The only way to check this now is to use debug version of the plugin code. Add this line to wp-config.php and it will trigger debug mode for scripts loading:

    define('SCRIPT_DEBUG', true);

    Add this line before this line:

    /* That's all, stop editing! Happy blogging. */

    If you already have SCRIPT_DEBUG definition, switch it from false to true. Let me know when you do this and I will try it again.

    Right now it looks like something is hooked to the elements in the slider and preventing it to execute events in my plugin. I went through the theme, and it has several pieces of code that attach themselves to all sorts of thing to cause problems. You can confirm that theme is the problem by switching to another theme and test it.

    Milan

    #1538
    robiul.islam
    Member

    Hi Milan,

    Thank you for your quick replay! I have added the line regarding your instruction. But the problem still there.

    I have checked the plugin with another theme and its work’s fine but it’s need to work with this theme (the7 theme) as our client request.

    Could you please help me to solve this issue?

    Best regards,
    Robiul

    #1539
    MillaN
    Keymaster

    Change I asked for is for debug purpose, it can’t solve the problem. But, I debugged everything I could and problem is that theme overrides all sorts of click handlers on the page, forcing many things to go through theme for some reason, preventing code in my plugin that handles click on the object too run. This is a problem with the theme, and there is nothing I can change in my plugin to fix that, theme needs to be fixed. Since it has a lot of JavaScript code, it is impossible for me to determine how it all works. You should contact theme author so he can see why his theme is doing that.

    Milan

    #1540
    robiul.islam
    Member

    Thank you Milan for your support!

    #1541
    MillaN
    Keymaster

    Let me know if theme author solves this.

    #2476
    rilco
    Member

    HI I’m having the same problem. Tab displays, but no slide out. Don’t know code and can’t locate wp-config file above. Could you have a look? Site is http://www.rilco.ie. Author of the theme is http://brandingbay.com/

    Thanks

    Ronan

    #2478
    MillaN
    Keymaster

    I can’t help you with theme problems. But, in your case things might be simpler, because there is a jQuery error on the page in code handling WP Emoji. Becuase of that problem, all jQuery code running after that one will fail. But, I have no idea how to fix the problem with WP Emoji. Once that is fixed, my plugin should work.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Simple Contact form dose not slide out.’ is closed to new replies.