• Creator
    Topic
  • #1779
    matthewbird
    Member

    Hello

    After moving out email provider the submitted forms from the slider are not going to the new inbox and keep going to the old email server.

    Is there any way i can correct this ?

    Thanks
    matt

Viewing 11 replies - 1 through 11 (of 11 total)
  • Author
    Replies
  • #1780
    MillaN
    Keymaster

    Hi,

    You have all options for emails in the plugin settings, and you can adjust it there. Did you made the change for delivery email when you made the switch?

    Milan

    #1782
    matthewbird
    Member

    We have not made any changes to the plugin since the email move

    #1784
    MillaN
    Keymaster

    That is my point. If you changed email, you need to change it in plugin settings too. Check out plugin settings for email delivery and check if you updated the email. If you don’t have email set at all in the plugin settings, plugin is using email set in WordPress settings.

    #1786
    matthewbird
    Member

    The email address has not changed just where it is hosted.

    I have tried un-ticking “Send to this email even when the Send To field is in use”
    Tried it as HTML rather than plain text
    Disabled and re-enabled the plugin

    #1788
    MillaN
    Keymaster

    Plugin has no idea (or it needs to know) where you email is hosted, it uses WordPress wp_mail function to send email to the email address you provided to on the plugin Email tab, you have option for ‘Send Email To’. Check that and confirm that you have correct email set there.

    #1790
    matthewbird
    Member

    I have tried that ticked and un-ticket

    The site contact form works ok but not the plugin which confuses me. Im just about to remove it and reinstall it

    #1792
    MillaN
    Keymaster

    Reinstall will not solve anything, no need to do it.

    If you have email set there, plugin will send email to that email address. Plugin does nothing else: each message goes to that email, that’s it. Option checkbox is used for something else, and it should be ticked.

    So, is the email in that field the same as the email you expect emails to arrive or not?

    Milan

    #1793
    matthewbird
    Member

    Say the email address before was info@mydom.com

    Before email move it was info@mydom.com
    Now it is the same of info@mydom.com after the move
    Both times the send to email address was ticked and the same address

    So the email address has not changed just we moved it from server to google mail for business. Normal emails and the contact form on the site hit the new google hosted box but the contact slider is hitting the old hosted server box :-S

    I dont understand how because the MX records have not completely changed and direct the email to google.

    #1795
    MillaN
    Keymaster

    My plugin doesn’t know where the email is, or where it is hosted, or whatever and it doesn’t need to know.

    My plugin needs the email address, and all the sending is done by WordPress through wp_mail function. So, my plugin takes email address you provided, builds email from contact details and calls WordPress function to send to your email. It doesn’t need to know anything else, send is totally up to WordPress and my plugin has absolutely no control over sending the email.

    This function returns to my plugin if the email is sent or not. If you get OK message after email is sent, that means that WordPress reported to my plugin that email is send, and my plugin again can’t do anything more about it.

    Email sending is WordPress job, and my plugin depends on that. What happens with the email, my plugin has no control over that. Try to see if there are some errors in the server error log for email sending.

    Milan

    #1844
    matthewbird
    Member

    I do apologize after looking over another section it would seem what there was an old MX record still within the server setup. After removing that the plugin worked fine

    Thanks
    matt

    #1845
    MillaN
    Keymaster

    OK, thanks for letting me know. If you have any problems, please let me know.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Sending to the wrong email box’ is closed to new replies.